博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
[2602]Bone Collector (HDU)
阅读量:5843 次
发布时间:2019-06-18

本文共 1597 字,大约阅读时间需要 5 分钟。

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 
 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 2 
31).
 

Sample Input

 
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

 
14
 
01背包
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
int w[1100],v[1100],bg[1100];
int main()
{
    int z,n,m,i,j;
    scanf("%d",&z);
    while(z--)
    {
        memset(bg,0,sizeof(bg));
        scanf("%d %d",&n,&m);
        getchar();
        for(i=0;i<n;i++)
            scanf("%d",&w[i]);
        for(i=0;i<n;i++)
            scanf("%d",&v[i]);
        for(i=0;i<n;i++)
        {
            for(j=m;j>=v[i];j--)//从后向前
            {
                if(bg[j]<bg[j-v[i]]+w[i])
                    bg[j]=bg[j-v[i]]+w[i];
            }
        }
        printf("%d\n",bg[m]);
    }
    return 0;
}

转载于:https://www.cnblogs.com/jiangyongy/p/3971655.html

你可能感兴趣的文章
SQL server查看触发器是否被禁用
查看>>
[C++基础]在构造函数内部调用构造函数
查看>>
跟随我在oracle学习php(8)
查看>>
Spring 3.1.0 Hibernate 3.0 Eclipse Spring WEB例子
查看>>
UVA-10212 The Last Non-zero Digit. 分解质因子+容斥定理
查看>>
求两个集合的交集,并集,差集
查看>>
Kotlin的语法糖(一)基础篇
查看>>
OkHttp源码分析
查看>>
让你的app体验更丝滑的11种方法!冲击手机应用榜单Top3指日可待
查看>>
windows kernel exploitation基础教程
查看>>
NS_OPTIONS枚举的用法
查看>>
QAQ高精度模板笔记√
查看>>
【Android笔记】入门篇02:全屏设置和禁止横屏竖屏切换
查看>>
Kubernetes的本质
查看>>
PL/SQL developer 管理多套数据库
查看>>
工作流编程循序渐进(8:状态机工作流)
查看>>
3.VMware View 4.6安装与部署-connection server(View Standard Server)
查看>>
Lync Server 2013 实战系列之六:标准版-安装和更新LyncServer 系统
查看>>
MariaDB日志审计 帮你揪出内个干坏事儿的小子
查看>>
Reporting Services目录临时数据库文件存在
查看>>